В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Hапишите программу на языка программирования паскаль АВС. Напишите программу в которой осуществляется ввод целых чисел(ввод осуществляется до тех пор, пока не будет введен ноль) и подсчет суммы и среднего арифметического введенных положительных чисел. Используйте оператор repeat

Ответ:
natashalixarev
natashalixarev
13.10.2020 02:09

program rabota;

var a,i,b,e:real;

begin

i:=0;

repeat

readln(a);

e:=e+a;

i:=i+1;

until a=0;

i:=i-1;

b:=e/i;

writeln('Сумма равна',e);

writeln('Среднее арифметическое равно',b);

end.

В крации: даны значения a=вводимого числа e=суммы чисел и b=среднее арифметическое

i=сколько чисел ты ввёл

Там будет i:=i-1 тк по задаче нужно ввести 0, но оно тоже считается и поэтому прибавляется i+1.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?