В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
7547854
7547854
26.11.2020 07:39 •  Информатика

Составить программу на языке си создайте функцию, которая принимает в качестве аргумента массив значений и возвращает наибольший элемент в массиве

Ответ:
Лизокккккек
Лизокккккек
05.10.2020 03:23
#include <stdio.h> 

int n=10;

int max(int x[n]) {
int m = x[0];
for (int i=1; i<n; i++) {
if (x[i]>m) m = x[i];
}
return m; 
}

int main() 

   int a[n];
   srand (time(NULL)); 
   for (int i=0; i<n; i++)  
   {
        a[i] = rand() % 1000;
        printf ("%5d", a[i]);
   }
    printf("\n");
    printf("max = %d", max(a));
    return 0;
}

Пример:
486 338 716 381 344 143 255 109 490 527
max = 716
0,0(0 оценок)
Ответ:
Lesha152
Lesha152
05.10.2020 03:23
#include <stdio.h>
#include <stdlib.h>
 int compare(void *a, void *b) {
    int va = *(int*)a;
    int vb = *(int*)b;
    if(va == vb) return 0;
    return va < vb ? -1 : 1;
}
 
int max_index(void *base, int n, int width, int (*compare)(void *a, void *b)) {
    int i, j = 0;
    char max[width];
    memcpy(max, base, width);
    for(i = 1; i < n; i++) {
        if( compare(base+i*width, max) > 0)
            {
                memcpy(max, base+i*width, width);
                j = i;
            }
    }
    return j;
}
 
int main() {
    int n;
    scanf("%d", &n);
    int a[n];
    for(int i = 0; i < n; i++)
        scanf("%d", &a[i]);
    printf("%d\n", a[max_index(a, n, sizeof(int), compare)]);
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?