Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
jojo31
18.12.2021 22:37 •
Информатика
Составить алгоритм и написать решение на паскале: три точки заданы своими координатами. найти длины сторон треугольника и его площадь.
Ответ:
lerafomina2004
05.10.2020 02:16
Program n1;
var: x1, y1, x2, y2, x3, y3, S, p, a, b, c: real;
begin
readln(x1,x2,x3,y1,y2,y3);
a=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
b=sqrt((x2-x3)*(x2-x3)+(y2-y3)*(y2-y3));
c=sqrt((x3-x1)*(x3-x1)+(y3-y1)*(y3-y1));
p=0.5*(a+b+c);
S=sqrt(p*(p-a)*(p-b)*(p-c));
writeln(S);
writeln(a,' ',b,' ',c);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
idalia444
10.08.2021 11:46
Запишите в десятичной системе счисления следующие числа: а2 =1010111, а8 = 517, а16 = 5e1...
revkova5a
10.08.2021 11:46
Назовите достоинства и недостатки растровой графики?...
nikita200310266xcute
15.12.2020 08:35
Написать программу которая рассчитывает количество населения города Мульти, если количество жителей ежегодно увеличивается на 7%. В текущем году оно составляет 50 000...
gigi24
26.03.2020 21:59
Напишите программу результат которой будет: Привет, мой дорогой друг!Привет! решить задачу: a=b*5Хорошо, введи значение b:6 ответ=30(на языке python) очень...
Zagadochnaya
05.02.2020 23:52
Закончи предложения так чтобы они стали суждениями и не суждениями исполнитель бумага звуковая информация...
tkach20
05.02.2020 23:52
Исправить программу. она должна вычислять среднее арифметическое всех чисел в массиве меньших 50. вот программа: program zadacha; uses crt; var a: array[1..1000] of integer;...
mamkin0poc
21.04.2020 13:33
1. базы данных — это: a) информационные структуры, хранящиеся во внешней памяти; b) программные средства, позволяющие организовывать информацию в виде таблиц; c) программные...
JesperWecksell
15.11.2022 21:10
Предложите мне мюзикл для домашней работы по музыке...
ARINA55T5
15.11.2022 21:10
Ширина прямоугольника равна 95 см, что составляет 5,12 длины. Найди площадь прямоугольника...
КОТ20052005Кот
30.07.2021 19:06
Тортайдың «Мен міне алмаған ақ боз бәлкім сен мінерсің.» дегенін қалай түсінесіз?3-4 сөйлеммен жаз...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var: x1, y1, x2, y2, x3, y3, S, p, a, b, c: real;
begin
readln(x1,x2,x3,y1,y2,y3);
a=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
b=sqrt((x2-x3)*(x2-x3)+(y2-y3)*(y2-y3));
c=sqrt((x3-x1)*(x3-x1)+(y3-y1)*(y3-y1));
p=0.5*(a+b+c);
S=sqrt(p*(p-a)*(p-b)*(p-c));
writeln(S);
writeln(a,' ',b,' ',c);
end.