В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
румия2408
румия2408
12.06.2021 13:39 •  Информатика

На c++ требуется написать программу, которая определяет цифры исходного четырёхзначного числа x и выводит их на экран. формат входных данных входной поток содержит целое число x (1000≤x≤9999) формат выходных данных выведите цифры числа xx по одному в строке, в следующем порядке: тысячи, сотни, десятки и затем единицы.

Ответ:
UGvu
UGvu
26.08.2020 06:05
#include <iostream>
using namespace std;

int main()
{
    int a, b;
    cout << "a = ", cin >> a, cout << "\n";
    b = a/1000;
    cout << b << "\n";
    b = a/100 % 10;
    cout << b << "\n";
    b = a % 100 / 10;
    cout << b << "\n";
    b = a % 10;
    cout << b << "\n";
    return 0;
}

Пример:
a = 7052
7
0
5
2
На c++ требуется написать программу, которая определяет цифры исходного четырёхзначного числа x и вы
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?