В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kuro111
Kuro111
29.01.2021 04:02 •  Информатика

Написать программу пользователь вводит 5 целых чисел,программа находит сумму всех отрицательных и произведение всех положительных чисел

Ответ:
ARTEMONUM
ARTEMONUM
19.07.2020 10:48
Uses CRT;
var i,s,p,a,n:integer;
begin
  p:=1; 
  write('введите кол-во чисел ');
  readln(n);
  for i:=1 to n do begin
                            write('введите ',i,'число: ');
                            readln(a);
                            if a<0 then s:=s+a
                            else p:=p*a
                          end;
 writeln('сумма отрицательных чисел равна: ',s);
 writeln('произведение всех положительных чисел равно: ',p)
end.
как-то так)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?