В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
annvggf
annvggf
23.01.2021 15:25 •  Информатика

Составьте программу на паскале, чтобы пк запросил имя пользователя и его год рождения, подсчитал возраст человека, в зависимости от возраста разработайте вариант диалога с пользователем (-ещё не учишься? ; -учишься где? ; уже не учишься? )

Ответ:
Люсии1г7у
Люсии1г7у
04.10.2020 22:13
Var
a,b,j,v,c:string;
q: integer;

begin
writeln('Напишите своё имя');
readln(a);
writeln('Напишите дату рождения, год целиком');
readln(q);
q:=2016-q;
write(' - Привет,',a,'. ');
if q<7 then begin writeln('Ты уже пошел в детский сад?'); readln (' - ',b);
if (b='Да') or (b='да') then writeln ('Удачи!') else writeln (' - Пойди в Детский сад, там тебя обучат азам жизни. Удачи')  end; else if (7<q) and (q<17) then begin writln (' - Ты пошёл в школу?'); readln (' - ',c); if (c='Да') or (c='да') then begin writeln (' - В какую школу ты пошёл?'); readln (' - ',v); writeln (' - В каком ты классе?'); readln (' - ',j);end;
end.

Так можно продолжать бесконечно
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?