В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alexaFat
alexaFat
17.03.2020 12:30 •  Информатика

20 1. составьте программу, которая формирует мас- сив из шестнадцати случайных целых чисел от-20 до 20 и: a) находит элементы с нулевыми значениями, б) находит индексы четных элементов; в) подсчитывает количество отрицательных эл ементов г) определяет, есть ли в этом массиве хотя бы одно число, кратное трем, д) находит в этом массиве индексы алементов значения которых кратны трем. на экран выводятся исходный массив и найденные элементы

Ответ:
Котик2841
Котик2841
04.10.2020 22:05
Program qq_a;
uses CRT;
const N=16;
var a:array[1..N] of integer; i:integer;
begin
for i:=1 to N do
begin
a[i]:=random((41)-20);
end;
for i:=1 to N do
if a[i]=0 then
writeln('a[',i,']=0')
else
writeln('Нет нулевых элементов');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?