В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aigylka764
aigylka764
20.05.2022 09:39 •  Информатика

Напишите программу на python.
напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 9. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 9

количество чисел не превышает 1000.ведённые числа по модулю не превышают 3.
программа должна вывести одно число: минимальное число,кратное 9

Ответ:
ZzitizZ
ZzitizZ
11.09.2020 13:53

kr = []

numers = []

numbers = int(input('Введите количество чисел в последовательности:\n'))

for i in range(numbers):

   new_el = int(input())

   numers.append(new_el)

for i in range(len(numers)):

   if numers[i] % 9 == 0:

       print(numers[i])

       kr.append(numers[i])

print(min(kr))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?