В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
shmitko85
shmitko85
20.09.2022 04:29 •  Информатика

Впаскале составить программу которая формирует массив из 16 случайных целых чисел в промежутке от -12 до 10 и подсчитывает кол-во элементов кратных 3

Ответ:
Taekook19
Taekook19
25.08.2020 23:58
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(16,-12,10); a.Println;
  Writeln('Кол-во кратных 3 элементов равно ',
    a.Where(x->x mod 3=0).Count)
end.

Пример
-12 -2 6 -10 8 2 -5 -2 4 5 -10 6 -12 1 -6 -8
Кол-во кратных 3 элементов равно 5

Впаскале составить программу которая формирует массив из 16 случайных целых чисел в промежутке от -1
0,0(0 оценок)
Ответ:
Madik1111111
Madik1111111
25.08.2020 23:58
При копировании кода на сайт из IDE автоматически убираются пробелы. Ниже будет скриншот того, как должен будет выглядеть код.

program zn; begin  var a: array [1..16] of integer;  var i, c: integer;  c:=0;  for i:=1 to 16 do   begin  a[i]:=random(20)-12;  writeln(a[i],' ');  if a[i] mod 3=0 then c:=c+1;  end;  writeln('Кол-во элементов кратных 3: ', c);  end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?