В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
abilgaziev1
abilgaziev1
12.11.2022 04:17 •  Информатика

Составить программу поиска элементов массива, значение которых совпадает с индексом.

Ответ:
Sonechka9youtobe
Sonechka9youtobe
08.09.2020 14:54
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace ConsoleApplication4
{
    class Program
    {
        static void Main(string[] args)
        {
            Console.WriteLine("Введи длину массива");
            int n = int.Parse(Console.ReadLine());
            int[] mass = new int[n];

            for (int i = 0; i < n; i++)
            {
                Console.WriteLine("Введи " + i + " элемент");
                mass[i] = int.Parse(Console.ReadLine());
            }

            for (int i = 0; i < n; i++)
            {
                if (i == mass[i])
                    Console.WriteLine("Элемент " + i + " совпадает со своим индексом");
            }

            Console.ReadKey();
        }
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?