В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alinakiseleva12
alinakiseleva12
14.05.2023 08:23 •  Информатика

Лёгкая по паскалю! , ! написать программу которая удаляет все точки і запятые из строки s.

Ответ:
aaa1616
aaa1616
04.10.2020 17:59
Решение для одного-двух разных удаляемых символов

// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  s:=s.Replace('.','').Replace(',','');
  s.Println
end.

Пример
> Раз, два, три, четыре, пять. Вышел зайчик погулять.
Раз два три четыре пять Вышел зайчик погулять

Решение, когда разных удаляемых символов может быть много

// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  s:=s.Where(с->not(с in [',','.'])).JoinIntoString;
  s.Println
end.
0,0(0 оценок)
Ответ:
LutsenkoRodion
LutsenkoRodion
04.10.2020 17:59
Pasca
program eazy;
var s:string;
i:integer;
begin
writeln('Vvedite tekst');
readln(s);
for i:=length(s) downto 1 do
if (s[i]=' ') or(s[i]=',') or (s[i]='.') then
delete(s,i,1) ;
writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?