В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
Otlichnica999
Otlichnica999
23.03.2020 08:37 •  Информатика

Написать программу, подсчитывающую количество четных и нечетных цифр в четырехзначном числе . ( в паскале с использованием цикла for)

Ответ:
Valik123211
Valik123211
03.07.2020 09:51
Var a,b1,b2,c,i:integer;
begin
readln(a);
for i:=1 to 4 do begin
c:=a mod 10;
if c mod 2 = 0 then b1+=1 else
b2+=1;
a:=a div 10;
end;
writeln('Четных - ',b1,' нечетных - ',b2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?