Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
rostislavcapsu
30.04.2020 19:51 •
Информатика
Написать программу по нахождению максимального элемента если элементы массива заполнены случайными числами в интервале от -50 до 50. (паскаль)
Ответ:
долин1
14.08.2020 13:32
1. Вот так это можно решить "по-современному".
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
Writeln('Max=',a.Max)
end.
Пример
n= 13
-11 16 -24 5 5 3 42 45 -46 45 22 43 -4
Max=45
2. А так учат в большинстве школ...
const
nn=100;
var
a:array[1..nn] of integer;
i,n,max:integer;
begin
Write('n='); Read(n);
randomize;
max:=-100;
for i:=1 to n do begin
a[i]:=Random(101)-50;
Write(a[i],' ');
if a[i]>max then max:=a[i]
end;
Writeln;
Writeln('Max=',max)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
НикитаПахомов1
26.11.2021 23:20
Чему в двоичной системе счисления равно число 65, которое записано в десятичной системе счисления?...
Эрюсик
24.04.2023 16:43
Вычислить сумму квадратов чисел от одного до n...
moxley00
24.04.2023 16:43
Как найти первые две цифры натурального числа в паскале?...
Лазоревка
28.09.2022 14:31
Составить программу для вычисления суммы натуральных чисел которые делятся нацело на 7 для массива от 1 до 100...
destroyer0800
28.09.2022 14:31
Составить программу для вычисления корня нелинейного уравнения по методу касательных х^2-cos(x^2)=6...
nelga2006дашуля
22.11.2020 13:28
Дан массив из n чисел, напишите программу которая будет складывать эти числа. ограничение: n =100...
tsoikin77
21.09.2022 19:07
Закодируй числовую информацию с цифрового алфавита,состоящего из двух знаков-цифр 0,1. числовая информация,закодированная текстом(буквами) двоичное число один 1 три...
dumargarita
22.01.2020 08:25
[сэкономленные байты]петя сконструировал устройство, состоящее из датчика и памяти. датчик снимает показания в диапазоне от 0 до 1.2 с точностью 0.1 и сохраняет в памяти...
Janna91
28.02.2022 05:52
Вexcel создать кроссворд на 4 слова с проверкой....
agroDan
28.02.2022 05:52
Какое количество слов, состоящих из букв слова экзамен, длиной 5 символов, начинающихся на букву э и оканчивающихся на букву м, возможно построить? ответ обосновать....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
Writeln('Max=',a.Max)
end.
Пример
n= 13
-11 16 -24 5 5 3 42 45 -46 45 22 43 -4
Max=45
2. А так учат в большинстве школ...
const
nn=100;
var
a:array[1..nn] of integer;
i,n,max:integer;
begin
Write('n='); Read(n);
randomize;
max:=-100;
for i:=1 to n do begin
a[i]:=Random(101)-50;
Write(a[i],' ');
if a[i]>max then max:=a[i]
end;
Writeln;
Writeln('Max=',max)
end.