В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Лазоревка
Лазоревка
28.09.2022 14:31 •  Информатика

Составить программу для вычисления суммы натуральных чисел которые делятся нацело на 7 для массива от 1 до 100

Ответ:
ccallul
ccallul
24.07.2020 21:11
Program mew;
var a: array [1..100] of integer;
sum,i: integer;
begin
sum:=0;
for i:=1 to 100 do
begin
a[i]:=random(100);
if (a[i] <> 0) and (a[i] mod 7 = 0)  then
begin
write(a[i], ' ');
sum:=sum+a[i];
end;
end;
writeln('Сумма равна',' ', sum);
end.
0,0(0 оценок)
Ответ:
Valeria13092004
Valeria13092004
24.07.2020 21:11
Var a:array[1..100] of integer;
i,s:integer;

begin
write ('vvardite  massiv=');
for i:= 1 to 100 do
readln(a[i]);
s:=0;
for i:= 1 to n do 
if (a[i]>0) and (a[i] mod 7 =0) then s:=s+a[i];
writeln(' summa cisel deliscihsia na 7'=,s);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?