Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Killyourself1
08.03.2021 02:03 •
Информатика
Кто сможет с по программированию? напишите программу в паскале для следующей (это 11 класс, тема "массивы"): заполнить массив а[15] числами 106, 112, 118, 124,
Ответ:
lenaguba1974ayp06vyr
04.10.2020 15:52
1. Современное решение
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var a:=106.Step(6).Take(15).ToArray; a.Println
end.
Результат
106 112 118 124 130 136 142 148 154 160 166 172 178 184 190
2. Древнее школьное решение "в лоб"
var
a:array[1..15] of integer;
i,k:integer;
begin
k:=106;
for i:=1 to 15 do begin
a[i]:=k;
k:=k+6;
Write(a[i],' ')
end;
Writeln
end.
3. Усовершенствованное древнее школьное решение.
Последовательность - арифметическая прогрессия с первым членом a₁=106 и разностью d=6.
Тогда
var
a:array[1..15] of integer;
i:integer;
begin
for i:=1 to 15 do begin
a[i]:=100+6*i;
Write(a[i],' ')
end;
Writeln
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
SweetCandy23228
23.02.2020 11:51
Задание по языку програм. Питон) Дано 3х значное числр. Определить, какая из его цифр больше: А) первая и последняя Б) первая и вторая В) вторая и последняя Входные...
Jullia123123
21.03.2020 12:02
Заполните пропуски: а) 6,2 Кбайт = … байт; б) 549 байт = … бит; в) 98304 бита = … Кбайт С решение и расчетами...
bog2017
20.01.2023 06:25
Создания этого устройства началась в 1984 году в японии. конкретно этот новый гаджет изобрёл японец фудзи масуока. в том виде, в каком оно используется сейчас,...
чашечкачая
02.02.2020 09:36
ЗА КРОССВОРД Нужно составить КРОССВОРД из 30 слов на тему информатика, программирование...
dvofgisf
01.05.2023 19:10
из бревна вырезают балку наибольшей площади. Найдите размеры сечения балки, если известен радиус сечения бревна. Оформите решение в виде компьютерной программы....
Ychi1ka
18.01.2022 06:10
Составьте программу в pascal abc, утраивающую каждую букву в заданной строке. пример ввода: кот пример вывода :...
trohy71
19.11.2022 12:25
Вкаких единицах измеряется пропускная каналов передачи информации?...
НяхаВай
06.03.2021 13:43
Составить программу Паскаль для нахождения площади кольца где t-толщина, а d- диаметр внутреннего кругадля программы paskalABC...
Neprostone
27.08.2022 21:00
1. Сколько поездов прибывают на станцию Минеральные Воды до 10:00? ответ на этот во запишите в ячейку I3 таблицы, используя формулу, 2. Чему равна наименьшая средняя...
moon137
23.01.2023 12:55
До ть нформатику балов даю, це програма Python ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var a:=106.Step(6).Take(15).ToArray; a.Println
end.
Результат
106 112 118 124 130 136 142 148 154 160 166 172 178 184 190
2. Древнее школьное решение "в лоб"
var
a:array[1..15] of integer;
i,k:integer;
begin
k:=106;
for i:=1 to 15 do begin
a[i]:=k;
k:=k+6;
Write(a[i],' ')
end;
Writeln
end.
3. Усовершенствованное древнее школьное решение.
Последовательность - арифметическая прогрессия с первым членом a₁=106 и разностью d=6.
Тогда
var
a:array[1..15] of integer;
i:integer;
begin
for i:=1 to 15 do begin
a[i]:=100+6*i;
Write(a[i],' ')
end;
Writeln
end.