В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ByArts1000
ByArts1000
03.07.2022 18:40 •  Информатика

Паскаль. написать программу которая, используя признаки делимости, определяет, делится ли число на 6. var a,c: integer; begin cls; randomize; a: =random (99999+99999+1)-99999; writeln ( 'исходное числo: ',a); if (a mod 10) mod 2 =0 then writeln (' делится на 2') else writeln (' не делится на 2'); while a< > 0 do begin c: = c+(a mod 10); a: = a div 10; end; if c mod 3 = 0 then writeln (' число делится на 3') else writeln (' число не делится на 3'); end. признак делимости на 6 - это значит, что число делится на 2 и 3. я сделала по отдельности на 2 и 3 ( программа выше). а как это обобщить?

Ответ:
sviktoria77777
sviktoria77777
04.10.2020 15:32
Var
    a, c: integer;

begin
    randomize;
    a := random(99999 + 99999 + 1) - 99999;
    writeln('исходное числo: ', a);
        
    while a > 0 do
    begin
        c := c + a mod 10;
        a := a div 10;
    end;
    
    if (c mod 3 = 0) and ((a mod 10) mod 2 = 0) then
        writeln(' число делится на 6')
    else
        writeln(' число не делится на 6');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?