В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Zetexer
Zetexer
19.06.2022 03:14 •  Информатика

Составьте программу , которая формирует массив из 12 случайных целых чисел из промежутка [160..180]. и уменьшает в 2 раза числа меньше среднего арифметического а больше среднего арифметического увеличивается в 2 раза . по информатике

Ответ:
витно
витно
31.08.2020 15:18
from random import randint
A = [randint (160, 181) for i in range(12)]
srznach = 0
print(A)
for i in range (12):
        srznach= srznach + A[i]
srznach = srznach/12
print(srznach)
for i in range (12):
        if A[i] <srznach:
                A[i] = A[i]/2
        else:
                A[i] = A[i]*2
print(A)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?