В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
butyuginap06qhe
butyuginap06qhe
15.04.2023 18:58 •  Информатика

Python написать программу, выводящую разложение бинома ньютона (a+b)^n (нахождение коэффициентов оформить в виде функции).

Ответ:
Cool281
Cool281
20.08.2020 06:21
Вычислений, конечно, много лишних. Можно оптимизировать.
def fact(m):
   f = 1
   for i in range(1,m+1):
      f = f*i
   return f

def koef(n,k):
   a = fact(n)
   b = fact(k)
   c = fact(n-k)
   return a//(b*c)

print("Введите n:")
n = int(input())
k = 0
while k <= n:
   print(koef(n,k),"*a^",n-k,"*b^",k,sep = '', end = '')
   k = k+1
   if k <= n:
      print(" + ",end = '')

Пример:
Введите n: 5
1*a^5*b^0 + 5*a^4*b^1 + 10*a^3*b^2 + 10*a^2*b^3 + 5*a^1*b^4 + 1*a^0*b^5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?