В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Найдите ошибки, , не понимаю, что надо исправить сама : составить программу, которая вычисляет сумму тех элементов двумерного массива, номера строк и столбцов которых принадлежат соответственно непустым множествам s1 и s2. var a: array[1..20] of integer; n,m,i,j,k: byte; sm,b: integer; s1,s2: set of byte; begin randomize; repeat write('количество строк='); readln(m); until m in [1..10]; repeat write('количество столбцов='); readln(n); until n in [1..10]; writeln('исходная матрица: '); for i: =1 to m do begin for j: =1 to n do writeln; end; writeln; writeln('множество s1: '); s1: =[]; for i: =1 to m do begin b: =random(m)+1; s1: =s1+[b]; end; for i: =1 to m do if i in s1 then write(i,' '); writeln; writeln('множество s2: '); s2: =[]; for i: =1 to n do begin b: =random(n)+1; s2: =s2+[b]; end; for i: =1 to n do if i in s2 then write(i,' '); writeln; writeln; sm: =0; for i: =1 to m do for j: =1 to n do if(i in s1)and(j in s2) then sm: =sm+a[1..20]; write('сумма=',sm); readln end.

Ответ:
Julai1234
Julai1234
04.10.2020 07:45
Четвёртая строка снизу:

if(i in s1)and(j in s2) then sm:=sm+a[1..20];

Вы к integer пытаетесь добавить array.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?