В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
basa4
basa4
05.11.2021 09:36 •  Информатика

6. составить алгоритм и написать программу вычисления суммы и среднего значения только отрицательных чисел из вводимых n произвольных (как положительных, так и отрицательных) целых чисел.n не больше 10

Ответ:
aleksandragapov
aleksandragapov
04.10.2020 06:48
Var a:array[1..100] of integer;
i,n,s,k:integer;
begin 
s:=0; k:=0;
write('Введите кол-во чисел: '); readln(n);
write('Введите числа: '); 
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if a[i]<0 then begin
s:=s+a[i];
inc(k);
end;
if k<>0 then 
begin writeln('Ср.знач. отрицательных чисел: ',s/k);
writeln('Сумма отрицательных чисел: ',s); end 
else writeln('Отрицательных членов нет');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?