Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
tim228904
28.03.2022 01:36 •
Информатика
Программа должна вывести одно число: максимальное число, оканчивающиеся на 9. входные данные: выходные данные: 3 19 9 19 23
Ответ:
MstyanKristina
25.08.2020 21:26
Var
n, max, i, d: integer;
begin
readln(n);
max := 0;
for i := 1 to n do
begin
readln(d);
if (d mod 10 = 9) and ((max < d) or (max = 0)) then
max := d;
end;
writeln(max);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
маринэджан
09.02.2023 09:50
С клавиатуры вводится последовательность целых чисел. Найти сумму чисел, посчитать количество чисел. Вывести полученные данные....
kozaksolomia1
21.02.2022 00:38
Составьте программу, которая формирует массив из десяти случайных чисел от -45 до 45 и меняет местами значение первого и последнего элементов...
сакина12
30.05.2020 21:43
Нужна презентация стартап-проекта в области информационных технологий. то есть, придумать какое-то изобретение в этой области, которого ещё нет в реальности, и описать его...
Мимиf
06.12.2022 17:00
Скорость передачи данных составляет 56000 бит/с.необходимо передать файл с размером 210000 байт.определите время передачи файла в секунда. можно подробно рассписать...
lenalatka
06.02.2021 19:15
Паскаль с клавиатуры вводится 2 числа первое-количество столбцов, второе-количество строк. построить таблицу (если например ввели 2; 3) таблица такая \1\1\ \1\1\ \1\1\...
ВладиславПрокофьев
12.04.2023 14:31
Перевод текста с английского на русский является процесом...
Саша5841
18.05.2020 03:33
Контрольная работа системы счисления Вариант 1.1. Перевести числа в десятичную систему:a. 24⁸; 10101²; 171⁶.b. 27⁸; 10100²; 141⁶.2. Перевести числа из десятичной системы счисления...
sonjasonjasonja
08.05.2022 18:46
Одна страница 256 строк,128 символов в одной строке система юникод ответ в !...
kategusha
14.09.2021 17:42
На каком этапе осуществляется целенаправленное извлечение и анализ информации о каком-либо объекте (процессе), в результате чего формируется образ объекта, проводится его опознание...
kylie333
14.09.2021 17:42
Разгодайте кроссворд : 1)как называется объект заменитель? 6 букв 2)средства взаимодействия человека и компьютера? 9ибукв 3)мыссленное объединение однородных объектов? 9 букв...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n, max, i, d: integer;
begin
readln(n);
max := 0;
for i := 1 to n do
begin
readln(d);
if (d mod 10 = 9) and ((max < d) or (max = 0)) then
max := d;
end;
writeln(max);
end.