В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
gelyusya
gelyusya
25.05.2023 06:12 •  Информатика

Дан одномерный вещественный массив из n чисел. написать программу нахождения суммы элементов массива стоящих на нечетных позициях (индекс). блок схема не нужна только программа 10

Ответ:
alinashelepova1
alinashelepova1
04.10.2020 05:21
Var
s:real;
n,i:integer;
a:array[1..1000] of real;

begin
write('Введите кол-во элементов: '); readln(n);
writeln('Введите элементы: ');
for i:=1 to n do 
read(a[i]);
s:=0;
for i:=1 to n do
if odd(i) then s:=s+a[i]; 
writeln('Сумма: ',s);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?