В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alekseqhhhh
alekseqhhhh
27.05.2021 21:33 •  Информатика

Написать программу для pascal abc: программа вводит 2 строки, затем из короткой строки вывод на экран символы, код которых больше 70, а из длинной строки – все цифры.

Ответ:
sjsdbj
sjsdbj
31.08.2020 11:52
//PascalABC.NET 3.2 сборка 1318

Var
  s1,s2,c:string;
  i:integer;
begin
write('Type s1:');
readln(s1);
write('Type s2:');
readln(s2);
if length(s1)>length(s2) then
  begin
    for i:=1 to length(s1) do
      if (s1[i]>='0') and (s1[i]<='9') then write(s1[i]);
    writeln;
    for i:=1 to length(s2) do
      if ord(s2[i])>70 then write(s2[i]);
  end
else
  begin
    for i:=1 to length(s1) do
      if ord(s1[i])>70 then write(s1[i]);
    writeln;
    for i:=1 to length(s2) do
      if (s2[i]>='0') and (s2[i]<='9') then write(s2[i]);
  end;
end.

Пример ввода:
Type s1:Mi Zu
Type s2:MeL10N
Пример вывода:
MiZu
10
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?