В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Olechka77
Olechka77
14.09.2021 15:23 •  Информатика

Составить программу, которая по введенному номеру и величине радиуса вычисляла: 1 - длину окружности, 2 - площадь круга, 3 - объем шара.

Ответ:
Kasha26336
Kasha26336
04.10.2020 03:35
Const
  Pi=3.1416;
var
  n:integer;
  r:real;
begin
  Write('Укажите вариант расчета и радиус: ');
  Read(n,r);
  case n of
  1:Writeln('Длина окружности равна ',2*Pi*r);
  2:Writeln('Пдощадь круга равна ',Pi*r*r);
  3:Writeln('Объем шара равен ',4/3*Pi*r*r*r)
  else Writeln('Вариант должет быть равен 1,2 или 3')
  end
end.

Пример
Укажите вариант расчета и радиус: 3 11.7
Объем шара равен 6708.8365344
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?