В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Werty0183
Werty0183
22.12.2020 17:28 •  Информатика

Pascal abc. составьте программу, которая рисует деталь в виде кольца внешним радиусом 150 и внутренним радиусом 50, в котором вырезаны отверстия радиусом 30. их центры находятся на расстоянии 100 от центра кольца (число отверстий n
вводится с клавиатуры). 2

Ответ:
мозг1101
мозг1101
23.05.2020 21:58
Program grapho; uses crt,graphABC; var xc,yc,r1,r2,rc,ro,n,i,x,y:integer;     a:real; begin repeat write('Количество отверстий от 3 до 7 n='); read(n); until n in [3..7]; clrscr; hidecursor; xc:=windowwidth div 2; yc:=windowheight div 2; r1:=50; r2:=150; rc:=100; ro:=30; a:=2*pi/n; circle(xc,yc,r2); circle(xc,yc,r1);   for i:=1 to n do  begin   x:=xc+round(rc*cos(a*i));   y:=yc-round(rc*sin(a*i));   circle(x,y,ro);  end; end.
0,0(0 оценок)
Ответ:
RBR13
RBR13
23.05.2020 21:58

program Risovalka;

  uses crt,graphABC;

  var xc,yc,r1,r2,rc,ro,n,i,x,y:integer;

  a:real;

    begin repeatwrite('ykashi shislo otverstii ot 5 do 10 n=');

    read(n);

   until n in [5..10];

   clrscr; hidecursor;

    xc:=windowwidth div 2;

    yc:=windowheight div 2;

   r1:=40;

   r2:=120;

   rc:=100; ro:=30;

   a:=2*pi/n;

   circle(xc,yc,r2);

    circle(xc,yc,r1);

     for i:=1 to n do  begin   x:=xc+round(rc*cos(a*i));

      y:=yc-round(rc*sin(a*i));

      circle(x,y,ro);

      end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?