В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
RomochkaRomashka
RomochkaRomashka
03.04.2022 20:42 •  Информатика

Дан массив a [1 .. 20] целого типа .составить программу замены отрицательных элементов на 0, положительных на 1

Ответ:
nazarkooo
nazarkooo
03.10.2020 21:22
//Создаем переменные
var  A: array[1..20] of integer;
i: integer;

begin
//Записываем рандомные значения в массив A
for i := 1 to 20 do
A[i] := random(-10, 10); //Указываем границы рандома (от -10 до +10 в данном случае)
//Проверяем числа массива
for i := 1 to 20 do
begin
if A[i] < 0 then A[i] := 0
else A[i] := 1;
end;
{writeln(A);}
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?