В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Roma765432112
Roma765432112
18.10.2021 04:05 •  Информатика

1) дан одномерный массив найдите сумму всех элементов массива , выведи на экран сам массив и сумму его элементов

2) дан одномерный массив найдите минимальный и максимальный элемент и выведите на экран​

Ответ:
pelmen123456789
pelmen123456789
12.10.2020 11:03

1)Program massiv;

Var mas:array[1..20] of integer;

a,b,i,sum:integer;

Begin

sum:=0;

For i:=1 To 20 Do

begin

mas[i]:= random(100); {Заполняем массив случайными числами в промежетке от 0 до 99 (можешь изменить промежуток}

write(mas[i],' ');

end;

Writeln('Введите a,b');

Readln(a,b);

For i:=1 To 20 Do

begin if (mas[i]>a) and (mas[i]<b) Then

sum:=sum+mas[i];

end;

Writeln(sum);

end.   

0,0(0 оценок)
Ответ:
2006Liora
2006Liora
12.10.2020 11:03

1) дан одномерный массив найдите сумму всех элементов массива , выведи на экран сам массив и сумму его элементов

1)Program massiv;

Var mas:array[1..20] of integer;

a,b,i,sum:integer;

Begin

sum:=0;

For i:=1 To 20 Do

begin

mas[i]:= random(100);

в промежетке от 0 до 99 }

write(mas[i],' ');

end;

Writeln('Введите a,b');

Readln(a,b);

For i:=1 To 20 Do

begin if (mas[i]>a) and (mas[i]<b) Then

sum:=sum+mas[i];

nd;

Writeln(sum);

end.   

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?