Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Ксюнька1801
05.09.2022 09:14 •
Информатика
Сложное по информатике: нужно написать программу на паскале, не используя if, then, else, с таким результатом: введите число если число четное, то вывести 10; если нечетное, то вывести -10
Ответ:
tuiyty
03.10.2020 20:44
Var a:integer;
begin
write('a = ');
readln(a);
writeln(-20*(abs(a) mod 2)+10);
end.
Пример:
a = 28
10
0,0
(0 оценок)
Ответ:
partsik95
03.10.2020 20:44
Var
n: integer;
res: boolean;
begin
readln(n);
res:=odd(n);
case res of
true: writeln('-10');
false: writeln('10');
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Aizadaserikova2004
10.11.2021 11:39
Из футбольной секции сказочной страны и выяснили, что каждый из них болеет за две футбольные команды суперлиги этой страны, за каждую команду болеет ровно 7 из них и...
SoktoevTimur
05.03.2022 11:34
Вывести на экран квадраты нечетных чисел от 1 до 9 при for, иначе не пойдет кто прваильно сделает- много паскаль...
aleksminaev
05.03.2022 11:34
Вывести на экран квадраты нечетных чисел, от 1 до 9...
2345tgbkl
26.02.2023 10:56
Встретились кошка с мышкой. и кошка сказала: если ты не принесёшь мне 10 капель волшебного масла, я тебя съем. а я тебе только два ведра. одно - вместимостью 15 капель,...
uvar13131
15.05.2023 10:13
Для какого из указынных значений числа x истинно выражение не(x 4)и(x 3)? 1)2 2)3 3)4 4)5 для какого из преведенных слов истинно логическое выражение (последняя буква...
екатерина700
01.11.2021 13:11
Известно что в классе 32 человека какой объём информации будет нести сообшение о том , что к доске пойдёт петя иванов...
ep53
01.11.2021 13:11
Подсчи айте в килобайтах количество информации в тексте если текст состоит из 800 символов , а мошьность используемого алшавита-128 символов...
Юля1ьагааащщн
11.03.2021 06:46
вообще не знаю что делать сделать ЛЮБОЕ из 2 или два если сможете .Отдаю все очки что есть ....
balabonkin68p06p8r
27.06.2020 04:04
Понятие «макроэкономика» впервые ввел в научный оборот: Дж.М. Кейнс П. Самуэльсон С. Кузнец А. Маршалл...
aikena2005
11.03.2021 06:46
как называлась книга, где герой это священнослужитель. Он всю зарплату раздавал бедным. И однажды в город приехал грабитель, но он не побоялся грабителя и все равно поехал...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
write('a = ');
readln(a);
writeln(-20*(abs(a) mod 2)+10);
end.
Пример:
a = 28
10
n: integer;
res: boolean;
begin
readln(n);
res:=odd(n);
case res of
true: writeln('-10');
false: writeln('10');
end;
end.