В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
soniy135
soniy135
12.02.2021 08:11 •  Информатика

Составить программу для вычисления значений функции f(x)= cos x + tg x на отрезке [a; b] с шагом h . результат представить в виде таблицы, первый столбец которой — значения аргумента, второй — соответствующие значения функции. pascal.

Ответ:
ЛераКоролёва13
ЛераКоролёва13
31.08.2020 08:08
Var
  a,b,h,x:real;
begin
  Write('Начальное значение, конечное значение, шаг: ');
  Read(a,b,h);
  x:=a;
  while x<=b do
    begin
    Writeln(x:7:4,cos(x)+tan(x):15:8);
    x:=x+h
    end
end. 

Контрольное решение
Начальное значение, конечное значение, шаг: -3 3 0.25
-3.0000    -0.84744595
-2.7500    -0.51138448
-2.5000    -0.05412132
-2.2500     0.61045399
-2.0000     1.76889303
-1.7500     5.34213387
-1.5000   -14.03068275
-1.2500    -2.69424731
-1.0000    -1.01710542
-0.7500    -0.19990759
-0.5000     0.33128007
-0.2500     0.71357050
 0.0000     1.00000000
 0.2500     1.22425434
 0.5000     1.42388505
 0.7500     1.66328533
 1.0000     2.09771003
 1.2500     3.32489204
 1.5000    14.17215715
 1.7500    -5.69862598
 2.0000    -2.60118670
 2.2500    -1.86680124
 2.5000    -1.54816591
 2.7500    -1.33722027
 3.0000    -1.13253904
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?