Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
geragyy
27.03.2021 15:45 •
Информатика
Написать программу в паскале: 1.удвоить заданное число, если оно положительное, утроить его, если оно отрицательно, и увеличит его на 1, если оно равно нулю.
Ответ:
NeGaTiV4iK1233
05.07.2020 08:53
Var a:real;
begin
readln(a);
if a>0 then a:=a*2;
if a<0 then a:=a*3;
if a=0 then a:=a+1;
writeln(a)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ishnlv
07.01.2021 17:10
это уже 2-я задача. Если не знаете не пишите дичь всякую ! В таблицу истиности ¬А- (A\/B/\C)...
дилирон1
26.12.2021 07:21
Контрольная по информатике ( с решением...
Инфузорияяя
15.02.2020 23:40
Обработка растровых изображений. Урок 2 Определи количество цветов, которые были использованы для инструмента «Ластик».1234НазадПроверить...
MissEmilyaBlood
31.12.2022 05:29
Даны действительные числаx, y (x≠ y). меньшее из этих двух чисел заменить их полусуммой, а большее – их удвоенным произведением. нужно решить в basic....
solnechnaya2
29.12.2020 17:26
Что такое ямб,хорей,дактиль? чем они отличаются?...
GiFka34
29.12.2020 17:26
Составьте уравнегния реакций взаимодействия: а)серы с алюминием. б) серы с углём(укажите степени окисления элементов и расставьте коэффициенты методом электронного...
kareta2004
29.12.2020 17:26
Чем вызвано недовольство фамусова 1 действие явление 4...
ДианаЛаймова2003
29.12.2020 17:26
Перевести на язык рассказ о моей комнате можно и перевод словами пр моя комната светлая, возле окна стоит стол за ним я делаю уроки. возле стола стоит диван на котором...
cempalov
29.12.2020 17:26
Сколько сообщений можно закодировать алфавитом, состоящим из 0 и 1 с длиной кода 4...
Glazkovanuriya
29.12.2020 17:26
Задайте линейную функцию y=rx формулой, если известно что ее график параллелен прямой 4x+y+7=0 б)определите, возрастает или убывает заданная вами линейная функция...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
readln(a);
if a>0 then a:=a*2;
if a<0 then a:=a*3;
if a=0 then a:=a+1;
writeln(a)
end.