В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
2001maks44
2001maks44
17.02.2020 05:34 •  Информатика

«бегущая строка». составить программу в паскале. которая изобразит в нижней части экрана строку, «бегущую» справа налево. строка должна менять свой цвет.

Ответ:
lusindrastsr
lusindrastsr
03.10.2020 18:44
Uses CRT;

Const
Delay = 200; //Задержка в миллисекундах
Line = 22; //Номер строки, на которой будет текст
Text = 'Бегущая строка'; //Текст бегущей строки

Var 
i: Integer;
s: String;

Begin
  s := Text;
  For i := 1 To 80 Do
  Begin
    GotoXY(1, Line);
    TextColor(Random(14) + 1); 
    WriteLn(s);
    s := ' ' + s;
    Sleep(Delay);
  End;
End.
0,0(0 оценок)
Ответ:
Анабель2032
Анабель2032
03.10.2020 18:44
//Pascal ABC.NET 3.1 сборка 1256

uses
  GraphABC; 

Const
 s='Sample text';//текст
 d=10;//задержка

 Var
 x:integer;
begin
randomize;
x:=windowwidth;
while x>=0 do
 begin
  textout(x,windowheight-20,s); 
 setfontcolor(rgb(random(255),random(255),random(255)));
  sleep(d);
  dec(x);
  clearwindow;
 end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?