Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
PeppaPig2222
24.11.2020 05:20 •
Информатика
Нужно написать программу на delphi: вводится кол-во переменных с клавиатуры на выходе 2 числа: сумма чисел, произведение квадратов. то есть "введите кол-во переменных" 2 3 3 сумма = 6 произведение квадратов = 81
Ответ:
Oloii
28.09.2020 17:49
Консольное приложение:
program Pr1;
{$APPTYPE CONSOLE}
var
N, a, i, s: integer;
p: double;
begin
WriteLn('Введите кол-во переменных ');
ReadLn(N);
s:=0;
p:=1;
for i:=1 to N do begin
ReadLn(a);
s:=s+a;
p:=p*a*a;
end;
WriteLn( 'Сумма = ',s);
WriteLn('Произведение квадратов = ',p);
ReadLn;
end.
Пример:
Введите кол-во переменных
5
4
6
2
7
3
Сумма = 22
Произведение квадратов = 1016064
0,0
(0 оценок)
Популярные вопросы: Информатика
alisakiseleva2
28.10.2021 11:47
Составить программу в паскале! 9 класс! ! даны вещественные числа х и у, не равные друг другу. меньшее из этих двух чисел заменить половиной их суммы, а большее — их удвоенным...
nikitarin0
28.10.2021 11:47
Составить программу в паскале! 9 класс! ! написать программу, по длинам сторон распознающую среди всех треугольников abc прямоугольные. если таких нет, то вычислить величину...
osapkina
28.10.2021 11:47
Составить программу в паскале! 9 класс! ! ! без всяких div и mod. год является високосным, если его номер кратен 4. из кратных 100 високосными являются лишь те года, которые...
kastalia2017
11.05.2021 02:45
Создание самого первого компьютера дата...
Nna564
11.05.2021 02:45
Определите значение переменной y после выполнения следующего фрагмента программы: х: =25; у: =20; while x*y 0 do; begin x: =x-5; y: =y+2; end;...
Azadamurshaeva
13.10.2022 18:29
Вычислить сумму положительных элементов массива...
logangeor
18.03.2023 08:08
Операционная система — это комплекс , обеспечивающих совместное функционирование всех устройств компьютера и предоставляющих пользователю ....
Ukine
03.08.2020 21:58
Ф.И.О.СПОРТ ПОЛ ВОЗРАСТ КЛУБ 1)Панько Л.П. футбол жен. 22 Спарта 2)Арбузов А.А. лыжи муж.20 Динамо 3)Жиганова П.Н. футбол жен.19 Ротор 4)Иванов О.Г. лыжи муж. 21 Звезда...
ArseniiB1
11.03.2020 12:55
Как готовят сметану? нужно на технологию ...
ksyushaivleva
11.03.2020 12:55
Образуй формы глаголов в повелительном наклонении Быть, помнить, бросить, давать, сознаваться...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
program Pr1;
{$APPTYPE CONSOLE}
var
N, a, i, s: integer;
p: double;
begin
WriteLn('Введите кол-во переменных ');
ReadLn(N);
s:=0;
p:=1;
for i:=1 to N do begin
ReadLn(a);
s:=s+a;
p:=p*a*a;
end;
WriteLn( 'Сумма = ',s);
WriteLn('Произведение квадратов = ',p);
ReadLn;
end.
Пример:
Введите кол-во переменных
5
4
6
2
7
3
Сумма = 22
Произведение квадратов = 1016064