В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
osapkina
osapkina
28.10.2021 11:47 •  Информатика

Составить программу в паскале! 9 класс! ! ! без всяких div и mod. год является високосным, если его номер кратен 4. из кратных 100 високосными являются лишь те года, которые кратны также 400 (например, 1700, 1800 и 1900 — не високосные года, 2000 — високосный). дано натуральное число n. определить, является ли високосным год с таким номером.

Ответ:
mashamaxi
mashamaxi
12.06.2020 21:25

programm p;

var n:integer;

begin

readln(n);

if n/4=int(n/4) then

begin

if (n/100=int(n/100))and(n/400<>int(n/400)) then

writeln('Не високосный') else

writeln('\Високосный';

end

else writeln('Не високосный')

 

end;

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?