Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
Показать больше
Показать меньше
sonyaflayps29
01.05.2023 05:36 •
Информатика
Ввести двумерный массив аnxm.каждый элемент в массиве чье значение лежит вне диапазона [-8; 6] возвести в квадрат.массив вывести до и после преобразования с++
Ответ:
4fhfhiukhriu
03.10.2020 18:33
#include <iostream>
//Размерность#define n 3#define m 3
//Диапозон#define d_min -8#define d_max 6
void enter_arr(int a[n][m]) { printf("\n >> Введите элементы массива %dx%d\n",n,m); for (int i = 0; i < n; i++) { printf("\n"); for (int j = 0; j < m; j++) { printf(" << a[%d][%d] = ", i+1, j+1); scanf("%d",&a[i][j]); } }}
void print_arr(int a[n][m]) { printf("\n >> Массив %dx%d :", n, m); for (int i = 0; i < n; i++) { printf(" \n >> "); for (int j = 0; j < m; j++) printf("%d ", a[i][j]); }}
int main(){ setlocale(LC_ALL, "rus"); int a[n][m];
enter_arr(a); print_arr(a);
for (int i = 0; i < n; i++) for (int j = 0; j < m; j++) if ((a[i][j] < d_min) || (a[i][j] > d_max)) a[i][j] *= a[i][j];
print_arr(a);
system("pause>>void"); return 0;}
0,0
(0 оценок)
Популярные вопросы: Информатика
сабина423
13.11.2020 16:48
5*((2*x-z)/(3+y*y)) составьте программу для решения примера в паскаль авс...
kcufka123456789
16.07.2021 11:09
1(в тетради для дз) написать программу, обрабатывающую поток водимых с клавиатуры целых чисел (пока не будет введен 0) и выводящую на экран количество введенных чисел,...
нананавай
31.01.2020 06:02
.файл размером 4200 кбайт передается через некоторое соединение в течение 7 минут. Определите скорость соединения...
belozerovyurik
19.07.2021 05:03
4. Определите очередность этапов создания компьютерной игры.A) Подготовить сценарий - определить идею — нарисовать персонажей.В) Определить идею - приготовить сценарий...
dead11dead
24.02.2023 02:49
1. Процеси, які повторюються, називають... а) скінченними;б) циклічними;в) командними.2. Речення, яке містить тасрдження про певний об єкт або про зв язки між об єктами,називають.а)...
Арина20071111
14.06.2022 19:57
Определите значение переменной b после выполнения алгоритма a= 5; b =2+a ;a=a*b ; b= 2*a-b...
tatsux2010
08.07.2022 15:32
от Pascal Вывести на экран таблицу умножения на число 5. Дан массив из 10 целых чисел. Найти сумму элементов больших 7....
lolsasafd
28.10.2022 19:05
обществознание 6 класс боголюбов краткий пересказ параграфа 11 отношения с окружающими...
ОсколковРоман
27.08.2020 06:09
с музыкой! Побудувати в h moll головні тризвуки з оберненням та розв язанням, D7 з оберненням та розв язанням. Скиньте фото ....
jdjehdbe
02.12.2021 01:19
Дана функция у = х — 1. При каких значениях х значение функции равно 8?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
//Размерность#define n 3#define m 3
//Диапозон#define d_min -8#define d_max 6
void enter_arr(int a[n][m]) { printf("\n >> Введите элементы массива %dx%d\n",n,m); for (int i = 0; i < n; i++) { printf("\n"); for (int j = 0; j < m; j++) { printf(" << a[%d][%d] = ", i+1, j+1); scanf("%d",&a[i][j]); } }}
void print_arr(int a[n][m]) { printf("\n >> Массив %dx%d :", n, m); for (int i = 0; i < n; i++) { printf(" \n >> "); for (int j = 0; j < m; j++) printf("%d ", a[i][j]); }}
int main(){ setlocale(LC_ALL, "rus"); int a[n][m];
enter_arr(a); print_arr(a);
for (int i = 0; i < n; i++) for (int j = 0; j < m; j++) if ((a[i][j] < d_min) || (a[i][j] > d_max)) a[i][j] *= a[i][j];
print_arr(a);
system("pause>>void"); return 0;}