В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kcufka123456789
kcufka123456789
16.07.2021 11:09 •  Информатика

1(в тетради для дз) написать программу, обрабатывающую поток водимых с клавиатуры целых чисел (пока не будет введен 0) и выводящую на экран количество введенных чисел, количество положительных, а также сумму и среднее арифметическое только положительных. можно решать через любой оператор цикла (кроме for). формат вывода: введено чисел_ из них положительных_ сумма положительных чисел_ среднее арифметическое положительных чисел_

Ответ:
LarisaSergeeva
LarisaSergeeva
09.10.2020 23:01

var a,k,p,s: integer;

begin  

repeat

write('Введите число: ');

readln(a);

if a<>0 then k:=k+1;

if a>0 then

begin

p:=p+1;

s:=s+a

end

until a=0;

writeln;

writeln ('Введено чисел_',k);

writeln ('Из них положительных_',p);

writeln ('Сумма положительных чисел_',s);

writeln ('Среднее арифметическое положительных чисел_',s/p:0:3);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?