В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
исл5
исл5
19.07.2020 23:15 •  Информатика

Напишите программу на turbo pascale дана последовательность x1 .. x30,среди положительных элементов найти максимальный и помножить на него все положительные элементы последовательности

Ответ:
LLarь
LLarь
28.09.2020 12:12
Писал в блокноте, возможны ошибки синтаксиса.

type Mas=array[1..30]of integer;
var i,Value:integer;
begin
for i:=1 to 30 do //заполняем последовательность
readln(Mas[i]);
//ищем максимальное значение
Value:=Mas[1];
for i:=2 to 30 do
if Mas[i]>Value then
Value:=Mas[i];
//умнажаем на максималку все положительные числа
for i:=1 to 30 do
if Mas[i]>0 then
Mas[i]:=Mas[i]*Value;
//вывод значений массива
for i:=1 to 30 do
write(Mas[i]," ");
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?