В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ddawka
ddawka
08.05.2020 01:41 •  Информатика

Написать программу в паскаль. дан массив целых чисел. найти количество пар соседних элементов, в которых одно число четное, а другое отрицательное. выведите также сформированный массив и все искомые пары соседних элементов.

Ответ:
Danil111112
Danil111112
03.10.2020 18:05
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  var b:=a.Pairwise; b.Println;
  Writeln('Найдено пар: ',
    b.Where(x->(x[0]<0) and x[1].IsEven or
      (x[1]<0) and x[0].IsEven).Count)
end.

Тестовое решение
n= 10
-37 -71 -71 -65 73 -66 -33 -85 62 -92
(-37,-71) (-71,-71) (-71,-65) (-65,73) (73,-66) (-66,-33) (-33,-85) (-85,62) (62,-92)
Найдено пар: 3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?