Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
8977288
03.03.2023 18:22 •
Информатика
)дан одномерный массив, содержащий целые числа. выполнить следующие действия: а) найти сумму четных элементов, больших заданного числа . ноль не учитывать. если таких элементов нет, вывести сообщение об этом.
Ответ:
rgmabbasov
28.09.2020 09:51
Int mas[N]; //данный массив длиной N
int k; // заданное число
int sum=0;// сумма
bool b = false; // были элементы или нет
for(int a=0;a<N;a++){
if(mas[a]>k&&mas[a]%2==0&&mas[a]!=0){
sum+=mas[a];
b=true;
}
}
if(!b) cout << "таких элементов нет";
else cout << sum;
0,0
(0 оценок)
Популярные вопросы: Информатика
егор1465
31.01.2020 10:01
Подчеркнуть ошибки в следующих фрагментах программ:...
Екатерина2088
16.12.2020 05:35
1 Определить состоит ли число введённое с клавиатуры из одинаковых цифр 2 Дано трëхзначное число, верно ли, что в числе все цифры различны 3 Определить является ли число...
MELEKLER87
30.04.2020 00:49
Тот кто получает принимает информацию...
iibixa1
30.04.2020 00:49
При работе с различными программами на панели можно отслеживать...
Наночкка
30.04.2020 00:49
Пользователь вводит какие то цифры,вывести это число увеличенное в три раза...
alinavolk93ozs1oc
30.04.2020 00:49
Вычислить значения функции c# вычислить значения функции y=4*x^3-2*x^2+5 для значений х, изменяющихся от -3 до 1, с шогам 0.1....
ilinasmirnova5
17.01.2023 20:28
Какую ошибку чаще всего делают начинающие программисты, программируя реверс массива?...
sprikutviktpria
05.05.2020 09:48
Синформатикой. найти y и х, если 225х=324y...
nevmer
29.01.2022 04:05
Написать этот пример на языке паскаль (цикл с параметром)...
drovniashinaan
07.10.2021 18:58
Все четырёхбуквенные слова, составленные из букв п, а, р, у, с, записаны в алфавитном порядке и пронумерованы, начиная с 1. начало списка выглядит так: 1. , 2. , 3. ,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
int k; // заданное число
int sum=0;// сумма
bool b = false; // были элементы или нет
for(int a=0;a<N;a++){
if(mas[a]>k&&mas[a]%2==0&&mas[a]!=0){
sum+=mas[a];
b=true;
}
}
if(!b) cout << "таких элементов нет";
else cout << sum;