В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
PavlWhite249
PavlWhite249
07.10.2020 18:38 •  Информатика

Написать программу, которая удаляет из введенного слова любой введенный с клавиатуры символ.слово вводится в программе. pascalabc

Ответ:
Lider4k
Lider4k
03.10.2020 18:03
// PascalABC.NET 3.1, сборка 1246 от 23.05.2016
begin
  var s:=ReadlnString('Введите слово:');
  var c:=ReadlnChar('Введите символ:');
  var p:=Pos(c,s);
  if p>0 then begin
    s:=s[:p]+s[p+1:];
    Writeln('Результат: ',s)
    end
  else Writeln('Такого символа в слове нет')
end.

Тестовое решение
Введите слово: информатика
Введите символ: м
Результат: инфоратика
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?