Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
VitaVita2003
16.02.2020 19:46 •
Информатика
Составьте программу ,увеличивающую четные элементы линейного массива a[1..n] на 1
Ответ:
klimsamgim923dushez
27.09.2020 18:57
Var
i,n:integer;
a:array [1..1000] of integer;
Begin
Read(n);
For i:=1 to n do
Read(a[i]); //вводим элементы массива
For i:=1 to n do begin
If a[i] mod 2 = 0 then inc(a[i]); //прибавляем 1 к четным элементам
Write(a[i], ' ');
End;
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
dasharuu
03.06.2023 08:08
2! по теме условный оператор 1) написать программу для вычисления стоимости покупки однородного товара ( например шоколад ) программа запрашимает кол-во товаров и цену одной единицы...
uylia144348
03.06.2023 08:08
Определите и напишите значение переменной x после выполнения операций присваивания: x: = 0 x: = x+1 y: = x x: = 2*y+2*x...
Tusovik
03.06.2023 08:08
По информатике! №1 деления) 10101 ² в десятичную ну,или хотя-бы объясните,как это решать!...
saruul708
14.10.2020 10:03
Почему для обработки текстовой информации на компьютере используется 256 символов...
Алёнушка290
27.07.2022 11:06
Информатика 7 класс якласс...
swetakorchagov
03.04.2021 12:57
Дан массив из 10 действительных чисел . увеличивающих каждый элемент в 3 раза и вывести печать изменения массива...
nastya632011
03.04.2021 12:57
По информатике. в школе 100 учеников. из них 14 девочек и42 мальчика. в какой системе счисления посчитаны ученики? а.3 б.5 в7 г6...
Мария017
03.04.2021 12:57
По информатике 7 класс . в каком из вариантов обьем информации равен 8 килобайт? а800 байт б12(13)бит в8160байт г2(бит)...
ДжонниМультяшка
03.04.2021 12:57
1000111111² = a^16 923^10 = a^12 79^16 = a^5 1050^8 = a^12 перевести двоичный код в шеснатиричный код и т.д (желательно с решением, хотя бы пару примеров)...
5ти
03.04.2021 12:57
Для какого имени истинно высказывание: первая буква гласная^четвертая буква согласнаяvв слове четыре буквы? 1) сергей 2) вадим 3) антон 4) илья...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i,n:integer;
a:array [1..1000] of integer;
Begin
Read(n);
For i:=1 to n do
Read(a[i]); //вводим элементы массива
For i:=1 to n do begin
If a[i] mod 2 = 0 then inc(a[i]); //прибавляем 1 к четным элементам
Write(a[i], ' ');
End;
End.