В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zephy
zephy
03.01.2020 23:45 •  Информатика

Напишите программу на паскале а.выясните какие числа ввел пользователь: положительное или отрицательное? б.выясните какие числа ввел пользователь: четное или нечетное ?

Ответ:
elvinpirimov1
elvinpirimov1
03.10.2020 17:09
//Pascal ABC.NET v3.1 сборка 1219

Var
 n:integer;
begin
 readln(n);
 if n>0 then writeln('Положительное');
 if n<0 then writeln('Отрицательное');
 if n=0 then writeln('0');
 if n mod 2=0 then writeln('Чётное') else writeln('Нечётное');
end.

Пример ввода:
1
Пример вывода:
Положительное
Нечётное
0,0(0 оценок)
Ответ:
arisazenina783
arisazenina783
03.10.2020 17:09
Var x:integer; 
begin 
writeln('Введите число'); 
readln(x); 
if x>0 then write('Число положительное и ') 
else write('Число отрицательное и '); 
if x mod 2=0 then write('четное.') 
else writeln('нечетное'); 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?