В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nikita577344
nikita577344
24.09.2022 07:00 •  Информатика

Составить программу на языке паскаль вводится натуральное число х (х> 9). 1. определить, ли по значению первая и последняя цифры.. например, ввод: 727 вывод: число начинается и заканчивается цифрой 7 ввод 123 вывод первая и последняя цифры не .

Ответ:
Эхэхэхэхэхэх
Эхэхэхэхэхэх
03.10.2020 14:40
Var a,b,c:integer;
begin
write('a = '); readln(a);
b:=a mod 10;
c:=a;
while c>9 do c:=c div 10;
if (a>9) 
 then if b=c
        then writeln('Число начинается и заканчивается цифрой ',c)
        else writeln('Первая и последняя цифры не совпадают')
 else writeln('Число < 10');
end.

Пример:
a = 65478
Первая и последняя цифры не совпадают
0,0(0 оценок)
Ответ:
Yourmom228black
Yourmom228black
03.10.2020 14:40
Прога в приложении
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?