В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
airamoon
airamoon
10.03.2021 02:10 •  Информатика

Написать программу нахождения наименьшей суммы двух соседних элементов массива

Ответ:
hikka137
hikka137
03.10.2020 14:42
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var a:=ArrRandom(ReadInteger('n='),10,99); a.Println;
  Writeln('Min. сумма соседних элементов: ',
    a.Pairwise.Select(x->x[0]+x[1]).Min)
end.

Тестовое решение
n= 15
72 22 71 77 41 89 73 54 29 47 47 46 98 82 15
Min. сумма соседних элементов: 76
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?