В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
hhhhh555550
hhhhh555550
02.06.2020 18:01 •  Информатика

Напишите программу которая в зависимости от введенной оценки в диапазоне от 1 до 12 выводит уровень к которому она относится c++​

Ответ:
shifu90
shifu90
09.10.2020 22:07

#include <iostream>

using namespace std;

int main() {

int n;

cin>>n;

switch (n)

{

case 1:

case 2:

case 3:

 cout<<"Неудовлетворительно";

 break;

case 4:

case 5:

case 6:

 cout<<"Удовлетворительно";

 break;

case 7:

case 8:

case 9:

 cout<<"Хорошо";

 break;

case 10:

case 11:

case 12:

 cout<<"Отлично";

 break;

default: cout<<"Ошибка ввода";

}

return 0;

}

Вот сам макет программы. Если нужны дугие уровни оценок - можно просто заменить выводимый текст на требуемый.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?