Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
мурзик55
19.12.2020 07:54 •
Информатика
Напишите программу, которая производит обмен згачений переменных x и y, если x больше y. пример входных пример выходных данных данных x> > 5 x=6 y> > 6. y=5 x> > 6 x=5 y> > 5. y=6
Ответ:
artemsavenkov
31.07.2020 18:48
Решение №1
var x,y:integer;
begin
readln(x,y);
if x> y then begin
x:=x+y;
y:=x-y;
x:=x-y;
writeln(x,' ',y);
end.
Тестовое решение:
8 5
5 8
Решение №2
На PascalABC.Net можно сделать проще:
var x,y:integer;
begin
readln(x,y);
if x>y then begin swap(x,y); println(x,y); end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
sofa286
27.05.2023 16:20
Развлечения в будущем. придумайте. пофантазируйте....
milka230614
02.05.2020 22:38
Уэльфов пропал волшебный жезл они заподозрили трех гномов сноука бигля и джойла все трое рассказали всё что они знали о пропаже . сноук: это не я . жезл взял бигль бигль:...
ulia09200413
10.08.2022 05:50
30 ! + лучший 1. у исполнителя квадратор две команды 1. возведи в квадрат 2. вычти 5 составьте алгоритм получения из числа 3 числа 6,содержащий не более 5 команд. 2. у исполнителя...
anechkaaa2
10.08.2022 05:50
Написать программу, которая переводит значение скорости v в размерерности м/сек в размерности км/час....
kicked102
07.03.2023 21:12
После преобразования растрового графического файла его объем уменьшился в 2 раза. сколько цветов было в палитре первоначально, если после преобразования было получено растровое...
bokkvika2908
07.03.2023 21:12
ответьте на вопросы по информатике 5класс 1)расскажите наглядных формах представления информации. 2)с какими наглядным формами представления информации вы знакомы ? свой пример...
CadetLada42
07.03.2023 21:12
Конспект по информатике: правила оформления таблиц...
XefforyGR
19.07.2020 14:08
Составить программу которая возводит в квадрат остаток от целочисленного деления числа а на 15 и выводит результат...
hcg1
12.02.2021 00:25
Дано вещественное число а.составить программу которая вычисляет целую часть числа а и выводит результат....
Liка25
06.09.2022 21:20
Написать программу,которая запрашивает возраст человека. если ему 18 и больше лет, то выводит сообщение совершеннолетний иначе - несовершеннолетний...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var x,y:integer;
begin
readln(x,y);
if x> y then begin
x:=x+y;
y:=x-y;
x:=x-y;
writeln(x,' ',y);
end.
Тестовое решение:
8 5
5 8
Решение №2
На PascalABC.Net можно сделать проще:
var x,y:integer;
begin
readln(x,y);
if x>y then begin swap(x,y); println(x,y); end;
end.