В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Rorshach
Rorshach
10.04.2023 05:36 •  Информатика

Решить программу с паскаля. в автобусе помещается 160 пассажиров, три четверти мест находятся в салонах эконом- класса и одна четверть - в салоне бизнес-класса. стоимость билета в салоне бизнес-класса составляет x рублей, что в два раза выше стоимости в салонах эконом-класса. определить прибыль авиакомпании, если непроданных билетов эконом-класса осталось а и непроданных билетов бизнес-класса осталось b.

Ответ:
lovchike
lovchike
03.10.2020 11:49
Летающий автобус)
1. Мест в эконом-классе 120, а в бизнес-классе 40.
2. 100 процентов прибыли получим, если заполним все места. Билет в эконом-классе стоит в 2 раза меньше чем X. Получаем следующее уравнение:
40*X + 0.5*120*X = 100%, X = 1% от всей прибыли.  Значит один билет в бизнес - классе приносит один процент прибыли. А один билет в эконом-классе приносит 0.5 процента прибыли.
3. Осталось рассчитать прибыль компании учитывая непроданные билеты:
P = 100 - b - 0.5*a  и написать программу:

var a,b:integer;
begin
  repeat
    writeln('Введите количество непроданных билетов (a,b)');
    readln(a,b);
  until (a<=120) and (b<=40)and (a>=0) and (b>=0);
  writeln('Прибыль компании составит ',100-b-0.5*a,'%');
end.

 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?