В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
J22UKR
J22UKR
29.03.2021 18:22 •  Информатика

Напишите программу паскаль для : 1)найти сумму и произведение натурального ряда от 1 до 10. 2)дано натурально число n.вычислить 2 в n степени. 3)дано натуральное число n.чему равна сумма его цифр?

Ответ:
tkacenkoaleksandra
tkacenkoaleksandra
23.09.2020 23:53
Program n1;
var a,b,sum,pr:integer;
begin
sum:=0;
pr:=1;
for a:=1 to 10 do begin
sum:=sum+a;
end;
writeln('сумма чисел от 1 до 10 = ',sum);
for a:=1 to 10 do begin
pr:=pr*a;
end;
writeln('произведение чисел от 1 до 10 = ',pr);
end.

program n2;
var a,b,n:integer;
begin
writeln('введите степень n');
readln(n);
b:=1;
for a:=1 to n do begin
b:=b*2;
end;
writeln('2 в ',n,' степени = ', b);
end.

program n3;
var sum,a,n,n2:integer;
begin
writeln('введите число n');
readln(n);
n2:=n;
while n<>0 do begin
a:=n mod 10;
sum:=a+sum;
n:=n div 10;
end;
writeln('сумма цифр ',n2,' = ',sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?