В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
masloshick
masloshick
06.06.2022 09:59 •  Информатика

Составить программу для решения : дана строка. проверить правильность написания слов с жи-ши. если слово написано неправильно,то исправить его.

Ответ:
жпжрдмдопнулуу
жпжрдмдопнулуу
03.10.2020 11:34
Var s:string; p1,p2:integer; 
begin
writeln('Введите слово:');
readln(s);
p1:=pos('жы',s);
p2:=pos('шы',s);
if (p1=0)and(p2=0) then writeln('Ошибок не замечено.');
if p1>0  then
 begin
 delete(s,p1,2);
 insert('жи',s,p1);
 writeln('Слово написано с ошибкой.');
 writeln('Правильное написание - ',s);
 end;
if p2>0  then
 begin
  delete(s,p2,2);
 insert('ши',s,p2);
 writeln('Слово написано с ошибкой.');
 writeln('Правильное написание - ',s);
 end;
end.
0,0(0 оценок)
Ответ:
uztstdgiDima
uztstdgiDima
03.10.2020 11:34
Var a:string;
i:longint;

begin
readln(a);
for i := 2 to length(a) do
begin
if (a[i] = 'ы') then
if (a[i-1] = 'ж') or (a[i-1] = 'ш') then a[i] := 'и';
end;

writeln(a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?