В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ninayurova51
ninayurova51
11.04.2021 14:55 •  Информатика

Дан одномерный массив из n вещественных элементов.составить программу вычисления их среднего нужно на завтра,

Ответ:
Євпак
Євпак
07.06.2020 04:59

program 1; 
uses crt; 
cоnst n=10; 
var arr:array[1..N] of real; 
sum:real; 
i:integer; 
Begin clrscr; 
writeln('Please entel array'); 
for i:=1 to N do 
read(arr); 
sum:=0; 
for i:=1 to N do 
sum:=sum+arr; 
writeln(); 
writeln("result=",sum/N); 
readln; 
End.

0,0(0 оценок)
Ответ:
adel2006buko
adel2006buko
07.06.2020 04:59

const N={задаём};

var a:array[1..N] of real; sr,summ:real; i:integer;

begin

  for i:=1 to N do

     read(a[i]);

  for i:=1 to N do

   summ:=summ+a[i];

    sr:=summ/N;

    write(sr);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?