Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Adalet555
07.02.2023 17:44 •
Информатика
Дан массив целых чисел, состоящий из 30 элементов. заполните его датчиком случайных чисел. найти: минимальный элемент массива и его порядковый номер.
Ответ:
Iulia1988
03.10.2020 10:31
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
var a:=ArrRandom(30,-20,20); a.Println;
Writeln('Минимум: A[',a.IndexMin+1,']=',a.Min)
end.
Тестовое решение:
8 20 2 2 -6 -11 7 20 -15 1 15 8 -1 13 -3 1 5 6 -6 -5 -2 13 -7 -7 -3 4 0 -7 10 5
Минимум: A[9]=-15
0,0
(0 оценок)
Популярные вопросы: Информатика
VZ1
19.01.2020 21:13
Составить программу на языке паскаль ввести с клавиатуры вещественное число a и целое число n ( 0). вывести все целые степени числа a от 1 до n....
kirrilkyplenow
30.04.2022 00:28
35 ! построить график функции: y = х^а + sin (b*x) при а = 0,8; b = 2,5; шаг h и значения х (не менее 15 значений) задать самостоятельно....
ukrkaravan757
14.12.2021 03:53
Массив содержит 20 элементов. определить количество положительных элементов в первой его половине и количество отрицательных элементов во второй. блок схему и программу...
zzizziz
05.09.2021 18:12
1)какое значение примет переменная b$ ? a$ = программа b$ = mid$ (a$,len( эвм )+2,3)+ a 2)составьте программу,которая в веденном предложении в каждом слове удаляет первую четверть...
Никитонрпаачвпр
05.09.2021 18:12
Слова презентация происхождение термина презентация...
lelikbalelik
15.06.2021 08:04
Вpascal ввести с клавиатуры 20 чисел. найти среднее арифметическое отрицательных...
dedovu6
15.06.2021 08:04
Было 53 груши, после того как каждую разрезали пополам,стало 136 половин. в какой системе счисления ввели счёт?...
kharchenko219633
15.06.2021 08:04
Это надо решить на python на сковородку одновременно можно положить k котлет. каждую котлету нужно с каждой стороны обжаривать m минут непрерывно. за какое наименьшее время...
avoka
03.01.2023 04:57
На что следуе обратить внимание при создании видео?...
помоги1361
22.01.2023 05:00
На вход в первой строке подается целое число A, во второй строке — целое положительное число N, а в третьей строке — массив из N целых чисел. Найти номер последнего элемента...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
var a:=ArrRandom(30,-20,20); a.Println;
Writeln('Минимум: A[',a.IndexMin+1,']=',a.Min)
end.
Тестовое решение:
8 20 2 2 -6 -11 7 20 -15 1 15 8 -1 13 -3 1 5 6 -6 -5 -2 13 -7 -7 -3 4 0 -7 10 5
Минимум: A[9]=-15